Inconsistency naming convention
And another more technical post :] Today I had occasion to fix some functions in my rendering code. It was look somehow like this: struct GPUBuffer { uint32 openGLBufferId; uint32 offset; uint32 size; }; ... class CGraphicsManager { ... /** @brief Create geometry buffer. */ bool createBuffers( GPUBuffer* a_buffer, uint32 a_sizeInBytes, uint8* a_ptr, bool a_dynamic); /** @brief Flush memory of geometry buffer. */ void flushBuffer( const GPUBuffer& a_buffer, uint32 a_offsetInBytes, uint32 a_sizeInBytes, const uint8* a_ptr); /** @brief Destroy geometry buffer. */ void destroyBuffers( GPUBuffer* a_buffer); ... }; So nothing special but I seen here two inconsistency in code convention. First is that once I use ...