Monday, July 27, 2015

Bug in rendering of editor

Week ago I wrote post about porting editor to linux. I was mentioning there this weird bug :
Editor works (Yes I know that drawing area is shifted to right. This is one of bugs that I still don't know why happening and I already spend on it like two days :/)
Which is really nicely visible on this screen shoot:


I spend on it like three days and still wasn't able to figure out why it happening or find any trace of it. I tried to ignore it but after noticing similar issues with blender and chrome I decided on desperate step. 

From my experience I know that upgrades of system never ending good. This is the reason why I try avoid them as much as it possible. But well sometimes you need to do stupid things so I decided to update my Linux (Ubuntu 14.04) and graphics card drivers (fglrx-14.301) to newest versions.

What went good: I was nicely surprised that system upgrade went without bigger problems. There were two steps 14.04 -> 14.10 -> 15.04 which took some time but except that I cannot complain.

What went wrong: Update of graphics card drivers. This is sad that after all this years you are not able to install driver without any problems. It took me half day of work, checking a lot of pages and in the end modifying source code of driver to make it work. This was just one line of code but still :/

Final result: Well decide yourselves:


It work how it should work but well I hate bugs like this. If I knew update of system would fix that I would spend 1 day on update not 3 days searching blindly what I doing wrong.

But well this is our developers reality: dealing with our bugs and bugs of others.

Greg

No comments:

Post a Comment